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Previous relevant session

Introduction to ImageJ Macros, Justin Savage, 03/06/2024



https://qlscenter.duke.edu/files/2024/07/Introduction-to-ImageJ-Macros.pdf

Outline

Virtual stack for viewing large data - macro-capable
Drift corrections - macro-capable

Big Data Viewer (vs Volume Viewer)

TrackMate - macro-capable

Mastodon = BDV + TM

a bk o0~

Please speak up with your own tips + anecdotes.



Quick tips for large data in FIJI

Allocate FIJI max memory to 75% of computer RAM - best practice -or whatever arbitrary high number you want - so
FIJI isn’t limiting factor Edit>Options>Memory & Threads

Read data locally or over wired (ethernet) connection
Subset data to only the relevant portion for your analyses (as a duplicate TIF file, etc)

Convert to 8-bit if you don’t need 16-bit res

Subsample: Image>Scale... reduce to desired pixel dimensions (e.g. 1024 —> 512) also have to reduce Z
When in doubt, clear the memory or close FIJI and reopen

Sometimes memory not released back to system after images are closed (even virtual)

More on clearing memory in a minute...

Open images as virtual stacks



Dealing with the memory backlog

[ (Fiji Is Just) Image) = O X
File Edit Image Process Analyze Plugins Window Help
Click status bar B o|c|o| /4t N A|o|m| A os | g 4] 8] |>
or (Fiji Is Just) ImageJ 2.14.0/1.54f, Java 1.8.0_322 [64-bit]; 456MB of 128000MB (£1%)rc to search
I4)' Memory —= X
Plugins>utilities>collect garbage
Plugins>utilities>monitor memory 211MB (<1%) Drag + drop here

for virtual stack

or Another user’s solution written in Groovy:

imp.flush() //flush the image

call(‘java.lang.System.gc’); 1J.wait(5000) //delay to collect the garbage

or System.gc() //run the garbage collection
https://forum.image.sc/t/memory-releasing-batch-processin
run("Collect Garbage"); g-scripting/60547

run("Fresh Start"); Equivalent in macro language (/ think equivalent):

or close(“WindowName”)
wait(5000) //wait 5000 milliseconds
Restart FlJI run(“Collect Garbage”)

run("Fresh Start")



1. Virtual Stack in Bio-Formats Importer

Plugins>Bio-Formats>
Bio-Formats Importer

20240806_memNG_Bung647_42hpf Ablation_TL_embryos02.czi (V.. —

vy N o

EE

(SIS

84 Bio-Formats Import Options

Stack viewing

View stack with: Hyperstack ke

Stack order:

Dataset organization

™ Group files with similar names
I~ Open files individually

[~ Swap dimensions

I~ Open all series

™ Concatenate series when compatible

[ stitch tiles

Color options

Color mode Default ¥

-

Metadata viewing Information

I Display metadata Use virtual stack - Only reads one image
plane into memory at a time, loading from
the data source on the fly as the active

image plane changes.

I” Display OME-XML metadata

I Display ROIs

This option is essential for datasets too large
to fit into memory.

ROIs Import Mode: - anage

Memory management

Split into separate windows

I~ Split channels
I~ Splitfocal planes

I~ Splittimepoints

Might help

with memory

issues?



Plugins > Bio-Formats >
Bio-Formats Plugin
Configurations

To enable as default
(probably already enabled)

Now drag+drop or
File>Open will use
bio-formats importer for
these file types

Bio-Formats Plugins Configuration

General Formats Libraries

Log

Tagged Image File Format

Tecan Spark Cyto

Text

TillVision

TopoMetrix

Trestle

Truevision Targa

UBM

Unisoku STM

VG SAM

Varian FDF

Veeco

Ventana .bif

Visitech XYS

Volocity Library

Volocity Library Clipping

WA Technology TOP

Windows Bitmap

Yokogawa CV7000

Zeiss AxioVision TIFF

Zeiss CZI

Zeiss LMS

Zeiss Laser-Scanning Microscopy

Zeiss Vision Image (ZVI)
Zip

Extensions czi

Enabled (V] $

Windowless

Attachment (] Include attachment images

Autostitch (V] Automatically stitch tiled images



Get professional help for large datasets and analysis

LMCF staff
IT staff in your Department
Research Computing support at Duke

Duke Center for Data and Visualization Sciences



&3 Correct 2D/3D Drift Options X

2. Drift Corrections

o

Channel for registration: |1 «

Many SO|Uti0nS, but I'll go over... ™ Correct only x & y (for 3D data):
Plugins>Registration>Correct 3D Drift ™ Multi time scale computation for enhanced detection of slow drifts?
VI rtua| Stack' I~ Sub pixel drift correction (possibly needed for slow drifts)?

I~ Edge enhance images for possibly improved drift detection?

Input: open TIF (as virtual Stack) in F1JI Only consider pixels with values larger than: |0

Start with a fresh instance of FIJI Lowest z plane to take into account:

Highestz plane to take into account: {302

11

Output: 3D registered TIF (unsaved) and 2D images saved in
folder specified when you run registration

Max shift x [pixels]: |100
Max shift y [pixels]: 100
Max shift z [pixels]: |100

To save yourself the headache, save the output TIF instead of v {Use virtuaistack for saving the resuits to disk to save RAM?:

trying to reconstruct it [ Only compute drift vectors?
It will be much larger than original (maybe 2x or more)

) Ifyou put a ROI, drift will only be computed in this region;
Then close FIJI or run garbage collection the ROI will be moved along with the drift to follow your structure of interest.

OK | Cancell




How the 3D Dirift correction works

Phase Correlation Correction Method
Based on fourier shift theorem

image2(x,y)=image1(x-tx,y—ty) for each pixel of a given two timepoints - but including z

Kuglin, C. D. and Hines, D. C., 1975. The Phase Correlation Image Alignment Method. Proceeding of IEEE International
Conference on Cybernetics and Society, pp. 163-165, New York, NY, USA.



Drift corrections of multiple channels

5D (3D, 2 channel, time)

Limited by computer RAM, even with virtual stack (FIJI not clearing memory
properly with 3D drift correct plugin)

| have to drift correct one channel and apply the correction to other channels

***Ask me for python script for applying drift to second channel if interested.



3. Big Data Viewer

For reslicing 3D and 3D+T big image data on any angle, quickly responsive Ul

Far more intuitive than orthogonal views (which have their benefits of course)

Check image z dimensions

Image>Properties.... Dimensions

Plugins>BigDataViewer>Open Current Image (I open in FIJI as virtual stack to
start)



How BDV works

Starts with low resolution mipmaps and loads higher resolution as those chunks are pulled into cache

Only loads into cache the relevant ‘chunks’ of your data at each resolution (ie blus vs red)

/]

O )

From https://imagej.net/plugins/bdv



File Settings Tools Help
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Cursor Xx,y,z
position displayed
in microns, as well
as timepoint

Hover over
righthand side to
open display editor




File Settings Tools Help BigDataViewer o O X

20250212 _memliG_Bungf47_SShpf_still-12_Cl.tif channel 1 =0 ¥ Display Modes

Single Source Neazest

¥ Sources

name current active color

Adjust display for
selected source

¥ Groups
group 1
group 2

group 3
group 4
group 5
group 6
group 7
group 8
group 9
group 10




Rotate with
image or with
cube of axes

File

Settings

Tools

Help

20250212_memliG_Bung647_SShpf_still-12 Cl.tif channel 1

¥ Display Modes

m®

Sirgle Source Neavest
¥ Sources

name current active

20250312._...

¥ Groups
group 1
group 2
group 3
group 4
group 5
group 6
group 7
group 8
group 9
group 10

O X
color

= 255

255 i




File Settings Tools Help BigDataViewer = O X

'.'0:5021:_1":"\!16_3\\1\9547_75hpf_st‘05.c1£ channel 2
 Sxoup 1

¥ Display Modes

0g 4

d Group Nearest

¥ Sources

name current active color
20250312_...

Display
from group

< group 1
20250312_memNG_Bung647_75hpf _still-

group 2
20250312_memNG_Bungb47_75hpf _still-

group 3

group 4

group 5

group 6

group 7

group 8




File Settings Tools Help

¥ Sources

Display from
source

name

¥ Groups

20250312_.
20250312_.

¥ Display Mo

DR 4

Fused Source Nearest

current active color
B (

o

group 1
20250312_memNG_Bung647_75hpf_still-

group 2
20250312_memNG_Bung647_75hpf_still-

group 3

group 4

group 5

group 6

group 7

group 8




Display from
single source

File

Settings

Tools

Help

- O X
Single  Source Neazest
¥ Sources
name current active color
20250312

—
20250312..... 2 | S

group 1
20250312_memNG_Bung647_75hpf _still-

group 2
20250312_memNG_Bung647_75hpf _still-

group 3

group 4

group 5

group 6

group 7

group 8




Display fused
sources

Display
nearest
neighbor
interpolation

File

Settings

Tools

BigDataViewer

/ /
vMUdCS/ -

Fused Source Nearest

¥ Sources

name current active color
20250312._... ® )
20250312_... —/

“ group 1
20250312_memNG_Bung647_75hpf_still-

V| group 2
20250312_memNG_Bung647_75hpf_still-

group 3

group 4

group 5

group 6

group 7

group 8




Display
tri-linear
interpolation

File

Settings

Tools

Help

BigDataViewer

:OCSOJLZ_m:mﬂG_B\ng47_75!\}75_:"05.txf channel 1

B

Y

O X
¥ Display Modes
Fused va:e Linear
¥ Sources
name current active color
20250312_... = )
20250312_.... [ ]

®) |V group1
20250312_memNG_Bung647_75hpf _still-

group 2
20250312_memNG_Bung647_75hpf _still-

group 3

group 4

group 5

group 6

group 7

group 8




The following table shows the available navigation commands using the mouse:

BDV Shortcuts

Rotate (pan and tilt) around the point where the mouse was clicked.

|4 LeftDrag|

®Right Drag | or| @ Middle Drag | Translate in the XY-plane.
https://imagej.net/ B .

@ Mouse Wheel | Move along the z-axis.

Dl uq I nS/de/ | 88 command | +| © Mouse Wheel | or | ¢ shift |+ * ctrl | +|  Mouse Wheel Zoom in and out.

The following table shows the available navigation commands using keyboard shortcuts:

x}[v}[z Select keyboard rotation axis.

S h if‘t to S peed - u p — Left},| — Right | Rotate clockwise or counter-clockwise around the choosen rotation axis.
(+Up,| v Down| Zoom in or out.

Ctrl tO S I OW_d Own Lh ‘:\ Move forward or backward along the Z-axis.
@\ bt g Rotate to the ZY-plane of the current source. (Look along the X-axis of the current source.)

th hortcut |

ese S Or Cu S ]@\*’ Xioriﬁﬂt +!M Rotate to the XZ-plane of the current source. (Look along the Y-axis of the current source.)

LT&\ + E Rotate to the XY-plane of the current source. (Look along the Z-axis of the current source.)
j\ or{ﬁi Move to previous timepoint.
J\ oriE Move to next timepoint.

For all navigation commands you can hold | 1 Shift | to rotate and browse 10x faster, or hold \ “Ctrlrl to rotate and browse 10x slower. For example, | — Left | rotates by 1°

clockwise, while| ¢ shift |+ | — Left | rotates by 10°, and [ * ctrl| +| — Left | rotates by 0.1°.



https://imagej.net/plugins/bdv/
https://imagej.net/plugins/bdv/

Video tutorial links

Awesome video tutorial on BDV, etc

https://voutu.be/LHI7vXiUUms?si=cbf7zzgbBNHIB W

Making videos with BDV

https://www.youtube.com/watch?v=vXu4ZOboEio



https://youtu.be/LHI7vXiUUms?si=cbf7zzgbBNHlB_IW
https://www.youtube.com/watch?v=vXu4ZOboEio

Plugins/Software that use BDV

3D Image handling/processing:

BigStitcher - image registration, fusion, and
deconvolution

BigWarp - elastic image alignment

BigVolumeViewer - 3D image rendering (vs
FluoRender)

BigDataProcessor2 - TB size data processing
Tracking:

MaMuT

Tr2D

Mastodon (more later...)

Segmentation/Pixel Classification:

LabKit
MetaSeg

Other Software:

Paintera



£ 20/81 L2691 4CR2) 60.26x59 58 um G49x1000 16-b 7ESNE

4. TrackMate

Automated or manual
tracking with nodes to
represent what you are
tracking and lines of fading
color to represent past
trajectory

Also makes tree of
node-node relationships in
time (e.g. cell divisions)

Many different tracking
algorithms to try - see
documentation if interested!

https://imagej.net/plugins/trackmate/tutorials/getting-started



https://imagej.net/plugins/trackmate/tutorials/getting-started

Help » Update... wait.... and click Manage update sites. Check the Mastodon
box. Close the window. Click Apply changes, then restart Fiji.

5 - M aStOd on Plugins>Tracking>Mastodon>MastodonLauncher

[or for older version Plugins>Mastodon (scroll to bottom of plugins list)]

#% Mastodon launcher = O X > o a
@ File Window Plugins Mastod.. — X
* new Mastodon project Reneastodon pojsct
» Views:

gﬁ new project from URL
— Browse to a BDV file (xml/h5 pair): ' e
L open Mastodon project E tab|e [g bdv

E selection table &+ trackscheme
& import oMM ' A
“ import MaMuT (®) Use an image opened in ImageJ: P =

rocessing:
% 20240806_memNG_Bungt47_42hpf_Ablation_TL_embryos02.czi v
3 import Simi-BioCell - et ¥
et Q‘ﬁ grapher ?g compute features

—“— configure tags

© / Sa\mlg:
‘}" save "‘_ \ Save as...
r— =t
create




BDV in Mastodon

Can use virtual stack with Mastodon, just like Big Data Viewer!

® File View Edit Window Plugins e

#® File Window Plugins Mastod.. — X .
Views: :- 4’
S table = b <4 . .
:;ﬂ selection table .,;, ‘ trackscheme
Processing:
% grapher 5!; compute features

‘\) configure tags

Saving:
¥ save

r—

Save as...

le




TrackScheme in Mastodon

: i—,_', Window View Edit Plugins  TrackScheme - 20240623_memNG_Bung647.. — (] X
Bt 2 3 comex | fiigmpn V| tmepoint0 spos0 Ese‘"""-" (==
I
@ File Window Plugins Mastod.. — X S | S S
Views:

R)- configure tags

Saving:

E save ‘ i sSave as... ’




Table in Mastodon (includes x,y,z coordinates)

/

@ File Window Plugin:

Views:
@ selection table

Processing:

table

}fﬁﬁ grapher
S‘_ configure tags
Saving:
“. save
r—

Can edit label for each node, can export to csv

Mactods — X ¥ File Window View Settings Plugins  Data table - 20240623_memNG_Bung647_TL_4Shpf 2embryos_30min-04... — O
) 1 52 K3 context | full graph v E Search ::":’
po; Spot Spot N links Spot frame Spot position Spot radius
i‘& bdv P Label ‘ ID Spot N links |N incoming...|N outgoing ... X ‘ Y ‘ z
Link (micron) (micron) (micron) (micron)
X1 trackscheme 0 0 1 0 1 1 149.736 157.267 100.725 1.381
- Hranchipct 1 1 2 1 1 2 151339 157089 100725 1381
. BranchLink 2 2 2 1 1 3 149.914 157.089 100.725 1.381
‘;ﬁ compute features 3 3 2 1 1 4 150.448 155.842 100.725 1.381
4 4 2 1 1 5 149.558 153.883 100.725 1.381
5 5 2 1 1 6 151.339 153.527 100.725 1.381
6 6 2 1 1 7 154,544 154.24 98.766 1.381
-iﬁ save as... 7 7 2 1 1 8 156.325 151.568 96.807 1.381
8 8 2 1 1 9 154.901 150.678 97.342 1.381
9 9 2 1 1 10 151.873 148.363 97.342 1.381
10 10 2 1 1 1 150.327 146.366 89.328 1.381
1 1 2 1 1 12 153.532 146.366 89.328 1.381
12 12 2 1 1 13 154.779 147.613 89.328 1.381
13 13 2 1 1 14 157.628 143.854 95.344 1.381



The three views can be locked together...and you can
open as many instances of each as you want!

& File View Edit Window Plugins

- 2 3 tmepont0 spots0

e renemmnsnemms - \\VNen locked, a node
selected in one view will be
selected and shown in the
other locked views.

ile Window View Edit Plugins TrackScheme - 20: ,_memNG_Bung647.

31 2 2 context: | full graph v | tmepine 0 spots0 8] se.
0
5 B File Window View Edit Settings Plugins T
2 21 G2 s context | ful graph v E Se i)
3 Spot Spot N links Spot frame | Spot position Spot radius
§ Label D Spot N links [N incoming...N outgoing .., X v
i | (micron) | (micron) | (micron) | (micron)
g ink
1 0 0 1 0 1 1 149.736 157.267 100.725 1.381

Lt BranchSpot :
= 1 1 2 1 1 2 151339 157.089 100725 1381
i BranchLink 2 2 2 1 1 3 149.914 157.089 100.725 1381
M 3 3 2 1 1 4 150448 155,842 100725 1381
0 4 4 2 1 1 5 149,558 153,883 100725 1381

5 5 2 1 1 6 151339 153,527 100725 1381

6 6 2 1 1 7 154,544 15424 98.766 1.381
24

7 7 2 1 1 8 156325 151,568 96.807 1381
»
- 8 8 2 1 1 9 154901 150678 97.342 1381
= 9 9 2 1 1 10 151.873 148,363 97.342 1381
= 10 10 2 1 1 " 150327 146,366 89.328 1381
e " " 2 1 1 12 153.532 146,366 89.328 1381
% 12 12 2 1 1 13 154779 147613 29.328 1.381
& 13 13 2 1 1 1 157.628 143.854 95.344 1381
4




Tracking Display in Mastodon BDV

& File View Edit Window Plugi ins gDat

Nodes show as spots

Links over time color from red (oldest) to
green (current timepoint in view)




Adjust display of nodes and links

& File View Edit Window Plugins BigDat 4062 emNG_B 47_TL_49hpf bryos =

In File>Preferences...

You'll find many settings to change view,
iIncluding spots and links, adding arrows,
coloring, etc...

Selecting a node changes its color,
scrolling through z will move things in and
out of focus - these settings are all editable




Shortcuts

More in the documentation online

https://mastodon.readthedocs.io/e
n/latest/docs/partB/table _bdv_nav

igation keys.html

Scroll along left-hand side for

several tables of shortcuts

Adding, deleting and modiying spots.

Add 3 new spot.

Mowe 3 spot.

Dedete 8 spot.

Change the radius of 3 spot.

Adding and linking spots.

Link ane spot to an existing one in the next frame.

Lirk ane spot to an existing ane in the prenous
frame

Add and Bk 3 8 spot in the next frame.

Add and lirik %o a spot in the previous frame.

Togghe the sutc-inking mode.

Removing links.

Dedetee 8 link.

Selection editing.

Add a spot / link to the seection.

Clearing the selection.

Remove selection content.

Undo / Redo.

Undo / Reda

Put the mouss 3t the desired posttion and press the & key.

Put the mouss nside a spot, press and hold sazce, and move the mouse to the desired positon.

Put the mouss niside 3 spot and press D

Put the mouss nside a spot and press Q (make 2 smaller) or £ (bigger).
Haold Shift 1o make larger changes or Control for finer changes.

Put the mouss inside 3 source =pot, and press and hold L.

The viewes moves 10 the next tlime-point and shows 3 preview of the fink.

Release the L key in the desired target spot. A fink iz created from the source spot to the target
spat.

Same procedure, but press Shaft L

Put the mouss inside 3 source =pot, and press and hald A,
The viewer moves 10 the next time-port, arestes 3 spot there and links i to the source spot
While holding 4, move the new 5pot 1o the desred locstion, snd rdesss A

Same procedure, but press Shift A

Control L

Put the mouss aver the fnk 1o delete and press 0

Shift click on 3 =potory ink to add / remove it 10 / from the seection

Click an an empty place of the smage.

Shift delete

Control Z/Control Snift 2


https://mastodon.readthedocs.io/en/latest/docs/partB/table_bdv_navigation_keys.html
https://mastodon.readthedocs.io/en/latest/docs/partB/table_bdv_navigation_keys.html
https://mastodon.readthedocs.io/en/latest/docs/partB/table_bdv_navigation_keys.html

Mastodon Documentation and Tutorials

https://mastodon.readthedocs.io/



https://mastodon.readthedocs.io/

Lean on the imagedJ community

https://forum.image.sc/

And the Duke QLS community


https://forum.image.sc/

Thanks!



